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How to deploy
SurveilStar PC/Internet Monitoring Software
(Latest updated: April. 9, 2015)

www.surveilstar.com
This document provides detailed guidelines on how to deploy SurveilStar PC/Internet monitoring software. Review the IT structure of SurveilStar employee monitoring system before getting started.
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1. SQL Server Requirement     
SurveilStar monitoring system requires a SQL data server to store and feed the collected data. SurveilStar Version after 3.27 supports SQL Server 2008 Express Edition as the built-in database engine. Microsoft® SQL Server® 2008 R2 Express is a powerful and reliable data management system that delivers a rich set of features, data protection, and performance. The SQL Server can be deployed on a dedicated computer or any computer deemed appropriate to be used as a data server.
System Requirement:
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  OS: Win2000 SP4/2003 SP1/XP SP2/Vista/Windows 7/8
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  Available Hard Disk Space: 2.2 GB of available hard disk space
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  RAM: Minimum of 512 MB of RAM (2 GB or more is recommended.)

Before installing SQL Server, you may need to update Windows Installer, .Net Framework and Windows PowerShell.
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  1. Download and install Microsoft .Net Framework 3.5 SP1
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  2. Download and install Windows Installer 4.5
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  3. Download and install Windows PowerShell 1.0
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  4. Download SurveilStar setup file then follow to install SQL Server 2008 & SurveilStar Server/Console/Agent.
2. Installing SQL Server 2008 & SurveilStar Server

SurveilStar Server should be installed in the same computer with the SQL Server application. Double-click the surveilstar setup file. If it pops up security warning message, please click Yes or Run button to continue.
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Choose Components:
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 1. If you have installed a previous version of SQL Server and don't need SQL Server 2008, please uncheck Microsoft SQL Server 2008 Express Edition. 
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 2. If you don't need to monitor the current server computer, please uncheck Install Agent Module on Local Computer. 
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 3. If you don't need Console in the server computer to view all surveilstar records, please uncheck SurveilStar V3 Console.
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Check all the information and click Install to continue the installation, or click Back if you want to review or change any settings.
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Installing SQL Server 2008 automatically. Please do not close the popup. It would take some time, please wait.
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Please wait while SQL Server 2008 R2 Setup processes the current operation.
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Installing SurveilStar on your computer. Please wait.
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Complete the SQL Server 2008 & SurveilStar setup. Click Finish to exit setup.
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3. Installing SurveilStar Console
The installation of SurveilStar Console uses the same setup file as installing the SurveilStar Server. Double-click the surveilstar setup file. Select SurveilStar V3 Console when prompted to select components, and then proceed.
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4. Installing SurveilStar Agent
SurveilStar Agent should be deployed to computers that are required to be monitored and controlled. The Agent can install in silence mode and run in stealth mode. There are 3 ways to deploy SurveilStar Agent to computers: 
[image: image23.png]


 1. Direct Installation
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 2. Remote Installation
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 3. Logon Script Installation.

Method 1: Direct Installation

Step 1. Create SurveilStar Agent setup file
On the desktop of the server, click "Start > All Programs > SurveilStar > Agent Installation Generator"
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Agent Installation Package Settings.
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 1. Server IP/Name: IP address of the server. Static IP and Dynamic DNS are supported.
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 2. Silent Installation: If you check this option, the Agent will install without showing any visible interface on agent computers. 
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 3. Account info: Installing SurveilStar Agent requires administrator privilege. Then you can try the account to run the setup file.
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 4. Save Setup File in: Choose a folder to save the setup file, and give it a file name.
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Step 2. Copy the setup file to target computers.
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Step 3. Double-click the setup file to install the Agent.
Method 2 : Remote Installation

Remote Installation can easily deploy SurveilStar Agent to a massive number of computers in remote and batch mode.
Step 1. Launch the remote installer
On the desktop of the server, click "Start > All Programs >SurveilStar > Agent Remote Installer"
Step 2. Scan network to find computers
By default, SurveilStar only scans computers from the server’s network segment. If you want to extend the searching area, go to menu "File > Scanning Settings", and specify an IP range. All computers available for remote installation will be listed as showed bellow.
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Step 3. Select computers to install SurveilStar Agent
Tick the checkbox before the computer host name that you want to install the Agent on it, and then click the menu "Operation > Install" to start remote installation, or click the install icon [image: image34.jpg]


 alternatively. 
Why does Remote Installation fail, and how to fix it
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  Administrator privilege needed. 
If the target computer is protected by password, you need to provide the administrator name and password of that computer to precede the installation, or the remote installation would fail.
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  The admin account is not shared via network. 
To see if the admin account (the ADMIN$ folder) is shared, you may use Command Prompt to check out the status.

On the desktop of Windows, click "Start > All Programs > Accessories > Command Prompt”, input the command line "net share”, and you will see if the ADMIN$ folder is shared.
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If the ADMIN$ is not listed, you can input "net share ADMIN$" to activate the account sharing.
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  There is no shared folder in the target computer.
 Even though it's remote installation, there should be a file folder that can be used by remote user to store the program files of the Agent. Please make sure the target computer has at least one file folder is shared, or you may need to create one on that computer.
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  Remote Installation only works on Windows NT4.0/2000/XP systems.
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  Remote Installation can fail sometimes due to the Windows NT local security settings. When Remote Installation fails, the best way is adopting the Direct Installation.

Method 3: Logon Script Installation
If the local area network (LAN) of your company has a domain server, you can use this method to deploy the Agent to computers within the LAN. 
Step 1. Download Script Manager

You can download Script Manger in either .rar or .zip file format.
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  Download Script Manager (in .rar file format)
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  Download Script Manager (in .zip file format)
Step 2. Put the Script Manager file folder to domain server

You may unzip the download RAR or ZIP package file, and then copy the Script Manager folder to the domain server. This folder should contain these files and document: LgnManV3.exe, IPGLgnV3.exe, and Readme.txt.

Step 3. Create a setup file of SurveilStar Agent
To create such file, refer to Create SurveilStar Agent setup file. The Agent setup file should be saved to the Script Manager folder as described in Step 2.

Step 4. Run LgnManV3.exe
Double-click the LgnManV3.exe executable file to open the Script Manager. The Logon Script Manager will automatically scan and show all computer users within the domain.
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Step 5. Select computers
Tick the check box before the user name to select computers. You can select multiple users so that the installation can be done at one time.
Step 6. Set installation script to target computers
When the selection of target computers is finished, click the Set Scripts button at the bottom of the manager window.
Step 7. Auto-installation
When a selected computer logs on to the domain, the preset script will run automatically to install SurveilStar Agent to that computer in stealth mode.
5. Creating monitor/control policies
A Control Policy describes when a PC/Internet activity is detected, what kind of action should be automatically taken against that activity. Control policy can be applied to the whole network, a certain group, or a selected computer/user.
User Policy > Computer Policy > Group Policy > Whole Network Policy

High priority < ------------------------------ > Low priority

You can assign one of the following policies to any specified PC/Internet activity:
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  Block the activity
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  Allow the activity
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  Inaction
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  Ignore the activity
You can take further actions against the detected activity:
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  Alert the administrator/supervisor
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  Send warning message to the monitored user
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  Lock/reboot the monitored computer

Click the Basic Policy or Advanced Policy tab in SurveilStar Console, and then click on a sub-tab to create new policy.
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 Add a new policy    [image: image55.jpg]
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 Move down
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 Delete policy        [image: image58.jpg]
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 Save policy

For instance, you can create a website policy to filter websites with porn content:
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6. Uninstalling SurveilStar
Note: If you want to remove the entire SurveilStar PC/Internet monitoring system, including Agents, Consoles and Server, please delete all SurveilStar Agents first. 
Otherwise, the deployed SurveilStar Agents will continue to run in those computers, even though the SurveilStar Server is removed. 
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 1. Uninstall Agent
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 2. Uninstall Console
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 3. Uninstall Server.

Uninstall SurveilStar Agent
Only IT manager or senior supervisor with administrator access to SurveilStar Console can uninstall SurveilStar Agent.
There are two methods to uninstall SurveilStar monitoring Agent:
Method 1: Uninstall Agent from SurveilStar Console

Login to the SurveilStar Console, right-click on any selected computer, or the entire network, and choose Uninstall Agent from the pop-up menu (as shown bellow).
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Note: Uninstalling an Agent does not delete the history data of this computer. The uninstalled Agent will still appear in the Console, marked in dark gray color. To delete an Agent completely, please click the Console menu "Tools > Computers”, select the computer name, and then click the Delete button.
Method 2: Uninstall Agent from the client computer
If the client computer is offline or is out of control of SurveilStar Console, you can uninstall the Agent directly from the computer.
Step 1: On client computer - create Operate Code
1. On the desktop of Windows, click "Start > Run", type "agt3tool ocularadv" command into the run box. 
2. Run the command, and you will see the Agent Tool.
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3. Select Uninstall Agent, and click the Generate button, you will see the Check Confirm Code form. This code is used to generate a confirm code from the Console (see next step).

Note: DO NOT close this Check Confirm Code form in this step. You need to return to this form later.
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Step 2: On SurveilStar Console - create Confirm Code
1. Go to SurveilStar Console, click the menu "Tools > Agent Tool > Confirm-Code Generator", you will see the Confirm Code Generator, enter the Operate Code attained previous step into the Agent Operate Code text area.
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2. Click the Parse button, and then click the Generate button, you will see the Confirm Code highlighted in blue color in a result form. Write down this code, and go to the last step.
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Step 3: Back to client computer - complete the un-installation
Now we are back to the client computer, where the uninstall operation is waiting to be confirmed.

Go to the Check Confirm Code form, enter the Confirm Code, and then click the OK button. Done.
Note: Uninstalling Agent does not delete history data of this computer. The uninstalled Agent will still appear in Console, marked in dark gray color. To delete an Agent completely, please click the Console menu "Tools > Computers”, select the computer name, and then click the Delete button.

Uninstall SurveilStar Console
On the desktop of Windows system, click “Start > All Programs > SurveilStar > Uninstall SurveilStar”, or go to "Control Panel > Add/Remove Program" to uninstall SurveilStar Server.

Uninstall SurveilStar Server
Note: Before uninstalling SurveilStar Server, all SurveilStar Consoles should be closed first.

On the desktop of Windows system, click “Start > All Programs > SurveilStar > Uninstall SurveilStar”, or go to "Control Panel > Add/Remove Program" to uninstall SurveilStar Server.
About SurveilStar Employee Monitoring Software

SurveilStar is the trustworthy PC/Internet monitoring software that secures your business and improves productivity. 

SurveilStar records and controls all computer and Internet activities - emails, web sites, chats and instant messages, program activities, document operations, removable devices, printers, and many more. 
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  Protect intellectual property and business secrets
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  Prevent and stop sabotage and data theft
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  Prevent Internet/email abuse
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  Reduce workplace slackers
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  Improve efficiency and productivity
SurveilStar is the trustworthy PC/Internet monitoring software that helps to secure your business and improve productivity and efficiency. SurveilStar is feature-rich, easy and intuitive.

SurveilStar records every detail of computer and Internet activities - emails, chats and instant messages, web sites visited, search history, program activities, document operations, printing, disc burning, movable devices, and many more. With SurveilStar, you can monitor everything they do on computers and the Internet. 
The surveillance screen snapshot feature enables you to see exactly what the monitored targets do on their computers, like you are watching behind them.

What’s important, SurveilStar puts you in control. Whatever you can monitor, you can control it. You can control certain computer’s access to websites, filter outgoing files via IM, block email attachment, disable movable device drive, cancel unauthorized file sharing, prevent changing system configurations, and many more. You can even lock the target computer if potential sabotage is out there.
Stealth mode, all-around records and reports, real-time multi-screen snapshot monitoring, dynamic PC/Internet control strategies, all these combine to build a complete solution for protecting your intellectual properties and business secrets, reducing slackers, prevent Internet and email abuse and related potential legal liability, and improve productivity.
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